IsFluidInUse Method


Fluid Type Is Fluid In Use Method

Identifies if the fluid type is in use.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsFluidInUse(
	Document document,
	ElementId fluidId
)

Parameters

document Document
The document.
fluidId ElementId
The id of the fluid type.

Return Value

Boolean
True if the fluid type is in use. False if the fluid type is not in use.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
If a fluid type is in use, it cannot be deleted.
See Also