ViewPrintedEventArgs Class


View Printed Event Args Class

The event arguments used by the ViewPrinted event.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ViewPrintedEventArgs : RevitAPIPostDocEventArgs

The ViewPrintedEventArgs type exposes the following members.

Properties
Name Description
Public property Cancellable Indicates whether an event may be cancelled by an event delegate.
(Inherited from RevitAPIEventArgs )
Public property Document The document associated with the event.
(Inherited from RevitAPIPostDocEventArgs )
Public property Index The index of the view being printed out of the set of all views being printed.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RevitAPIEventArgs )
Public property Status Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler).
(Inherited from RevitAPIPostEventArgs )
Public property TotalViews The number of all views being printed.
Public property View The view that was printed.
Top
Methods
Name Description
Public method Dispose
(Inherited from RevitAPIEventArgs )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method IsCancelled Indicates whether the event is being cancelled.
(Inherited from RevitAPIEventArgs )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also