GetMovedBarTransform Method


Rebar Get Moved Bar Transform Method

Returns a transform representing the movement of the bar relative to its default position along the distribution path.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Transform GetMovedBarTransform(
	int barPositionIndex
)

Parameters

barPositionIndex Int32
The bar index.

Return Value

Transform
The transform representing the movement of the bar relative to its default position along the distribution path.
Exceptions
Exception Condition
ArgumentOutOfRangeException barPositionIndex is not in the range [ 0, NumberOfBarPositions-1 ].
See Also