GetMovedBarTransform Method


Rebar Get Moved Bar Transform Method

Returns a transform representing the movement of the bar relative to its default position along the distribution path.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public Transform GetMovedBarTransform(
	int barPositionIndex
)

Parameters

barPositionIndex Int32
The bar index.

Return Value

Transform
The transform representing the movement of the bar relative to its default position along the distribution path.
Exceptions
Exception Condition
ArgumentOutOfRangeException barPositionIndex should be in range [ 0, NumberOfBarPositions-1 ] and the bar at barPositionIndex should be included.
See Also