Macro Class


Macro Class

An individual Autodesk Revit Macro which can be executed.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Macros Macro

Namespace: Autodesk.Revit.DB.Macros
Assembly: RevitAPIMacros (in RevitAPIMacros.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Macro : IDisposable

The Macro type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property MacroModule The Macro module.
Public property Name The macro name.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the Macro
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method Execute Executes the macro.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also