Linear |
Creates a new instance of an Linear Dimension element within the project.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static LinearDimension Create(
Document document,
View dbView,
Line line,
IList<Reference> references
)
Parameters
- document Document
- The document where new Linear Dimension is created.
- dbView View
- The view in which the Linear Dimension will appear.
- line Line
- The line of the annotation
- references IList Reference
- references that the Linear Dimension will witness.
Return Value
LinearDimensionThe newly created Linear Dimension instance, or if the operation fails.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |