ConnectionInputPoint Class


Connection Input Point Class

An object that holds information about a connection input point
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure ConnectionInputPoint

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ConnectionInputPoint : IDisposable

The ConnectionInputPoint type exposes the following members.

Constructors
Name Description
Public method ConnectionInputPoint Construct a default input point.
Public method ConnectionInputPoint(XYZ) Construct an input point from 3d point. A new valid id will be auto-generated.
Public method ConnectionInputPoint(XYZ, Guid) Construct an input point from 3d point and id.
Top
Properties
Name Description
Public property Id Unique id of this input point.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Point 3d position of this input point.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ConnectionInputPoint
Top
See Also