Connection |
An object that holds information about a connection input point

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ConnectionInputPoint type exposes the following members.

Name | Description | |
---|---|---|
![]() | ConnectionInputPoint | Construct a default input point. |
![]() | ConnectionInputPoint(XYZ) | Construct an input point from 3d point. A new valid id will be auto-generated. |
![]() | ConnectionInputPoint(XYZ, Guid) | Construct an input point from 3d point and id. |

Name | Description | |
---|---|---|
![]() | Id | Unique id of this input point. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | Point | 3d position of this input point. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the ConnectionInputPoint |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |