Link |
An output node that represents a linked Revit document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The LinkNode type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode ) |
![]() | NodeName | A readable name of the output node. (Inherited from RenderNode ) |
![]() | SymbolId | Identifies the Id of the symbol associated with the node. |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from RenderNode ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetDocument | Returns the document associated with the link. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetTransform | A transformation matrix associated with the node. (Inherited from GroupNode ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

See also: OnLinkBegin(LinkNode) .