LinkNode Class


Link Node Class

An output node that represents a linked Revit document.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB RenderNode
Autodesk.Revit.DB GroupNode
Autodesk.Revit.DB LinkNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class LinkNode : GroupNode

The LinkNode type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RenderNode )
Public property NodeName A readable name of the output node.
(Inherited from RenderNode )
Public property SymbolId Identifies the Id of the symbol associated with the node.
Top
Methods
Name Description
Public method Dispose
(Inherited from RenderNode )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetDocument Returns the document associated with the link.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetTransform A transformation matrix associated with the node.
(Inherited from GroupNode )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
See also: [!:Autodesk::Revit::DB::IExportContext::OnLinkBegin] .
See Also