LinkNode Class


Link Node Class

An output node that represents a linked Revit document.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB RenderNode
Autodesk.Revit.DB GroupNode
Autodesk.Revit.DB LinkNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class LinkNode : GroupNode

The LinkNode type exposes the following members.

Properties
Name Description
Public property SymbolId Identifies the Id of the symbol associated with the node.
Top
Methods
Name Description
Public method GetDocument Returns the document associated with the link.
Top
Remarks
See also: [!:Autodesk::Revit::DB::IExportContext::OnLinkBegin] .
See Also