UIFabricationUtils Class


UIFabrication Utils Class

General Fabrication UI utility methods in Revit UI.
Inheritance Hierarchy
System Object
Autodesk.Revit.UI UIFabricationUtils

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class UIFabricationUtils

The UIFabricationUtils type exposes the following members.

Methods
Name Description
Public method Static member GetOpenConnectorIndicatorAwayColor Gets the color of the open connector indicator in away direction.
Public method Static member GetOpenConnectorIndicatorPlanColor Gets the color of the open connector indicator in plan view.
Public method Static member GetOpenConnectorIndicatorTowardsColor Gets the color of the open connector indicator in towards direction.
Public method Static member SetOpenConnectorIndicatorAwayColor Sets the color of the open connector indicator in away direction
Public method Static member SetOpenConnectorIndicatorPlanColor Sets the color of the open connector indicator in plan view.
Public method Static member SetOpenConnectorIndicatorTowardsColor Sets the color of the open connector indicator in towards direction
Top
See Also