Set3DContextHandle Method


Exporter IFC Set 3DContext Handle Method

Sets the IfcRepresentationContext or IfcRepresentationSubContext handle to be used for 3D entities (Model entities).

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void Set3DContextHandle(
	IFCAnyHandle contextHandle,
	string subContextName
)

Parameters

contextHandle IFCAnyHandle
The IfcRepresentationContext for 3D entities.
subContextName String
The name of the IfcRepresentationSubContext, or the IfcRepresentationContext if the string is empty, for 3D entities.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also