AreDetailElements Method


Detail Element Order Utils Are Detail Elements Method

Indicates if the elements are all detail elements that participate in detail draw ordering in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool AreDetailElements(
	Document document,
	View view,
	ICollection<ElementId> detailElementIds
)

Parameters

document Document
The document.
view View
The view in which the details appear.
detailElementIds ICollection ElementId
The details to check.

Return Value

Boolean
True if the detail elements are orderable in the view, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also