PrimarySizeCriterion Class


Primary Size Criterion Class

This class contains a size criterion for a RoutingPreferenceRule.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB RoutingCriterionBase
Autodesk.Revit.DB PrimarySizeCriterion

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PrimarySizeCriterion : RoutingCriterionBase

The PrimarySizeCriterion type exposes the following members.

Constructors
Name Description
Public method PrimarySizeCriterion Constructs a PrimarySizeCriterion with a minimum and maximum size.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RoutingCriterionBase )
Public property MaximumSize The maximum size of this criterion.
Public property MinimumSize The minimum size of this criterion.
Top
Methods
Name Description
Public method Static member All Creates a criterion with a range of all sizes.
Public method Dispose
(Inherited from RoutingCriterionBase )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method IsEqual Verify if two criteria are the same.
(Inherited from RoutingCriterionBase )
Public method Static member None Creates a criterion with a range of no sizes.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also