Primary |
This class contains a size criterion for a RoutingPreferenceRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The PrimarySizeCriterion type exposes the following members.

Name | Description | |
---|---|---|
![]() | PrimarySizeCriterion | Constructs a PrimarySizeCriterion with a minimum and maximum size. |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RoutingCriterionBase ) |
![]() | MaximumSize | The maximum size of this criterion. |
![]() | MinimumSize | The minimum size of this criterion. |

Name | Description | |
---|---|---|
![]() ![]() | All | Creates a criterion with a range of all sizes. |
![]() | Dispose | (Inherited from RoutingCriterionBase ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | IsEqual | Verify if two criteria are the same. (Inherited from RoutingCriterionBase ) |
![]() ![]() | None | Creates a criterion with a range of no sizes. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |