Primary |
This class contains a size criterion for a RoutingPreferenceRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The PrimarySizeCriterion type exposes the following members.

Name | Description | |
---|---|---|
![]() | PrimarySizeCriterion | Constructs a PrimarySizeCriterion with a minimum and maximum size. |

Name | Description | |
---|---|---|
![]() | MaximumSize | The maximum size of this criterion. |
![]() | MinimumSize | The minimum size of this criterion. |

Name | Description | |
---|---|---|
![]() ![]() | All | Creates a criterion with a range of all sizes. |
![]() ![]() | None | Creates a criterion with a range of no sizes. |