FamilySymbolProfile Class


Family Symbol Profile Class

Represents a family symbol based profile for sweep or swept blend elements.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FamilySymbolProfile : SweepProfile

The FamilySymbolProfile type exposes the following members.

Properties
Name Description
Public property Angle The angle of the rotation of the profile in radians.
Public property IsFlipped Indicates if the symbol profile is flipped or not.
Public property Code example IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property Profile Returns the family symbol of the profile.
Public property XOffset The offset of the profile to the origin of the sketch plane in the X direction.
Public property YOffset The offset of the profile to the origin of the sketch plane in the Y direction.
Top
Methods
Name Description
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
Use objects of this type in methods as NewSweep() and NewSweptBlend() in FamilyItemFactory to create the profile.
See Also