Family |
Represents a family symbol based profile for sweep or swept blend elements.

System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB SweepProfile
Autodesk.Revit.DB FamilySymbolProfile
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB SweepProfile
Autodesk.Revit.DB FamilySymbolProfile
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The FamilySymbolProfile type exposes the following members.

Name | Description | |
---|---|---|
![]() | Angle | The angle of the rotation of the profile in radians. |
![]() | IsFlipped | Indicates if the symbol profile is flipped or not. |
![]() | Profile | Returns the family symbol of the profile. |
![]() | XOffset | The offset of the profile to the origin of the sketch plane in the X direction. |
![]() | YOffset | The offset of the profile to the origin of the sketch plane in the Y direction. |

Name | Description | |
---|---|---|

Use objects of this type in methods as NewSweep() and NewSweptBlend() in FamilyItemFactory to create the profile.