Point Class


Point Class

A 3D point.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Point : GeometryObject

The Point type exposes the following members.

Properties
Name Description
Public property Coord Returns the coordinates of the point.
Public property Code example GraphicsStyleId The ElementId of the GeometryObject's GraphicsStyle
(Inherited from GeometryObject )
Public property Id A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement.
(Inherited from GeometryObject )
Public property IsElementGeometry Indicates whether this geometry is obtained directly from an Element.
(Inherited from GeometryObject )
Public property Code example IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property Reference Returns a stable reference to the point.
Public property Visibility The visibility.
(Inherited from GeometryObject )
Top
Methods
Name Description
Public method Static member Create(XYZ) Creates a point at the given coordinates.
Public method Static member Create(XYZ, ElementId) Creates a point at the given coordinates and assigns it the specified GraphicsStyle.
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified Object is equal to the current Object .
(Inherited from GeometryObject )
Public method GetHashCode Gets the integer value of the geometry object as hash code
(Inherited from GeometryObject )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
The point lies at a given XYZ coordinate location.
See Also