Point Class


Point Class

A 3D point.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Point : GeometryObject

The Point type exposes the following members.

Properties
Name Description
Public property Coord Returns the coordinates of the point.
Public property Reference Returns a stable reference to the point.
Top
Methods
Name Description
Public method Static member Create(XYZ) Creates a point at the given coordinates.
Public method Static member Create(XYZ, ElementId) Creates a point at the given coordinates and assigns it the specified GraphicsStyle.
Top
Remarks
The point lies at a given XYZ coordinate location.
See Also