Point Class |
A 3D point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The Point type exposes the following members.

Name | Description | |
---|---|---|
![]() | Coord | Returns the coordinates of the point. |
![]() ![]() | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle (Inherited from GeometryObject ) |
![]() | Id | A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement. (Inherited from GeometryObject ) |
![]() | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject ) |
![]() ![]() | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject ) |
![]() | Reference | Returns a stable reference to the point. |
![]() | Visibility | The visibility. (Inherited from GeometryObject ) |

Name | Description | |
---|---|---|
![]() ![]() | Create(XYZ) | Creates a point at the given coordinates. |
![]() ![]() | Create(XYZ, ElementId) | Creates a point at the given coordinates and assigns it the specified GraphicsStyle. |
![]() | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject ) |
![]() | Equals | Determines whether the specified Object is equal to the current Object . (Inherited from GeometryObject ) |
![]() | GetHashCode | Gets the integer value of the geometry object as hash code (Inherited from GeometryObject ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

The point lies at a given XYZ coordinate location.