Index |
The base class for DirectContext3D index streams, which are used to write vertex indices into buffers.

System Object
Autodesk.Revit.DB.DirectContext3D IndexStream
Autodesk.Revit.DB.DirectContext3D IndexStreamLine
Autodesk.Revit.DB.DirectContext3D IndexStreamPoint
Autodesk.Revit.DB.DirectContext3D IndexStreamTriangle
Autodesk.Revit.DB.DirectContext3D IndexStream
Autodesk.Revit.DB.DirectContext3D IndexStreamLine
Autodesk.Revit.DB.DirectContext3D IndexStreamPoint
Autodesk.Revit.DB.DirectContext3D IndexStreamTriangle
Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The IndexStream type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the IndexStream |

This base class cannot be used directly. Instead, a steam that is specific for each type of primitive (point, line, or triangle) must be used.
- Use IndexStreamPoint to insert IndexPoint instances.
- Use IndexStreamLine to insert IndexLine instances.
- Use IndexStreamTriangle to insert IndexTriangle instances.
- Map the index buffer (see IndexBuffer ).
- Get a stream for the appropriate primitive type from the buffer.
- Add sequences of indices corresponding to primitives of the same type to the stream. The indices will be written into the buffer that was used to create the stream.
- Unmap the buffer.