IndexStream Class


Index Stream Class

The base class for DirectContext3D index streams, which are used to write vertex indices into buffers.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IndexStream : IDisposable

The IndexStream type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the IndexStream
Top
Remarks
This base class cannot be used directly. Instead, a steam that is specific for each type of primitive (point, line, or triangle) must be used. The process of putting vertex indices into a buffer involves using a stream-buffer pair as follows:
  1. Map the index buffer (see IndexBuffer ).
  2. Get a stream for the appropriate primitive type from the buffer.
  3. Add sequences of indices corresponding to primitives of the same type to the stream. The indices will be written into the buffer that was used to create the stream.
  4. Unmap the buffer.
As an alternative to using streams, it is possible to write data into a buffer using a handle to its mapped memory.
See Also