InitialFluxIntensity Class


Initial Flux Intensity Class

This class encapsulates initial flux intensity calculation.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Lighting InitialIntensity
Autodesk.Revit.DB.Lighting InitialFluxIntensity

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class InitialFluxIntensity : InitialIntensity

The InitialFluxIntensity type exposes the following members.

Constructors
Name Description
Public method InitialFluxIntensity(Double) Creates an initial flux intensity object with the given document and flux values.
Public method InitialFluxIntensity(InitialFluxIntensity) Creates a copy of the given initial flux intensity object
Top
Properties
Name Description
Public property Flux The flux intensity value.
Public property InitialIntensityValue The calculated initial intensity value.
(Inherited from InitialIntensity )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from InitialIntensity )
Top
Methods
Name Description
Public method Clone Creates a copy of the InitialIntensity derived object.
(Inherited from InitialIntensity )
Public method Dispose
(Inherited from InitialIntensity )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also