LocationCurve Class


Location Curve Class

Provides location functionality for all elements that are based upon a curve.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class LocationCurve : Location

The LocationCurve type exposes the following members.

Properties
Name Description
Public property Code example Curve Provides the ability to get and set the curve of a curve based element.
Public property ElementsAtJoin Get all elements joining to the end of this element's location curve or change the order of elements participation in the end join with this location curve's end.
Public property Code example IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property JoinType Get/change the type of the join at the specified end.
Top
Methods
Name Description
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method Code example Move Move the element within the project by a specified vector.
(Inherited from Location )
Public method Code example Rotate Rotate the element within the project by a specified angle around a given axis.
(Inherited from Location )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
The location line objects adds additional functionality to its base location object class. This includes reading and writing the curve contained within the element.
See Also