LocationCurve Class


Location Curve Class

Provides location functionality for all elements that are based upon a curve.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class LocationCurve : Location

The LocationCurve type exposes the following members.

Properties
Name Description
Public property Code example Curve Provides the ability to get and set the curve of a curve based element.
Public property ElementsAtJoin Get all elements joining to the end of this element's location curve or change the order of elements participation in the end join with this location curve's end.
Public property JoinType Get/change the type of the join at the specified end.
Top
Methods
Name Description
Top
Remarks
The location line objects adds additional functionality to its base location object class. This includes reading and writing the curve contained within the element.
See Also