Location |
Provides location functionality for all elements that are based upon a curve.

System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB Location
Autodesk.Revit.DB LocationCurve
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB Location
Autodesk.Revit.DB LocationCurve
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The LocationCurve type exposes the following members.

Name | Description | |
---|---|---|
![]() ![]() | Curve | Provides the ability to get and set the curve of a curve based element. |
![]() | ElementsAtJoin | Get all elements joining to the end of this element's location curve or change the order of elements participation in the end join with this location curve's end. |
![]() ![]() | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject ) |
![]() | JoinType | Get/change the type of the join at the specified end. |

Name | Description | |
---|---|---|
![]() | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() ![]() | Move | Move the element within the project by a specified vector. (Inherited from Location ) |
![]() ![]() | Rotate | Rotate the element within the project by a specified angle around a given axis. (Inherited from Location ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

The location line objects adds additional functionality to its base location object class. This includes reading and writing the curve contained within the element.