Plan |
An object that represents an enclosed area in a plan view within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The PlanCircuit type exposes the following members.

Name | Description | |
---|---|---|
![]() | Area | The enclosed area of the circuit. |
![]() | IsRoomLocated | Reports whether there is a room located in this circuit. |
![]() | SideNum | The number of sides in the circuit. |

Name | Description | |
---|---|---|
![]() | GetPointInside | Returns a point inside the circuit. |

Plan circuits are enclosed regions as seen on a plan view. They are used to determine the boundary extents of rooms based on the placement of walls. In the Autodesk Revit API, you can use plan circuits to create new rooms.