PlanCircuit Class


Plan Circuit Class

An object that represents an enclosed area in a plan view within the Autodesk Revit project.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PlanCircuit : APIObject

The PlanCircuit type exposes the following members.

Properties
Name Description
Public property Area The enclosed area of the circuit.
Public property IsRoomLocated Reports whether there is a room located in this circuit.
Public property SideNum The number of sides in the circuit.
Top
Methods
Name Description
Public method GetPointInside Returns a point inside the circuit.
Top
Remarks
Plan circuits are enclosed regions as seen on a plan view. They are used to determine the boundary extents of rooms based on the placement of walls. In the Autodesk Revit API, you can use plan circuits to create new rooms.
See Also