ElementWorksetFilter Class


Element Workset Filter Class

A filter used to match elements which reside in a given workset.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ElementWorksetFilter : ElementQuickFilter

The ElementWorksetFilter type exposes the following members.

Constructors
Name Description
Public method ElementWorksetFilter(WorksetId) Constructs a new instance of a filter to match elements in a given workset.
Public method ElementWorksetFilter(WorksetId, Boolean) Constructs a new instance of a filter to match elements in a given workset.
Top
Properties
Name Description
Public property WorksetId The workset id.
Top
Methods
Name Description
Top
Remarks
This filter is a quick filter.
Example
public void WorksetElements(Document doc, Workset workset)
{
    // filter all elements that belong to the given workset
    FilteredElementCollector elementCollector = new FilteredElementCollector(doc);
    ElementWorksetFilter elementWorksetFilter = new ElementWorksetFilter(workset.Id);
    ICollection<Element> worksetElemsfounds = elementCollector.WherePasses(elementWorksetFilter).ToElements();

    // how many elements were found?
    int elementsCount = worksetElemsfounds.Count;
    String message = "Element count : " + elementsCount;

    // Get name and/or Id of the elements that pass the given filter and show a few of them
    int count = 5;  // show info for 5 elements only
    foreach (Element ele in worksetElemsfounds)
    {
        if (null != ele)
        {
           message += "\nElementId : " + ele.Id;
           message += ", Element Name : " + ele.Name;

          if (0 == --count)
              break;
        }
    }

    Autodesk.Revit.UI.TaskDialog.Show("ElementsOfWorkset", message);
}
See Also