GetInstances Method


IFCFile Get Instances Method

Gets IFC instances of one particular type.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<IFCAnyHandle> GetInstances(
	string entityName,
	bool includeSubTypes
)

Parameters

entityName String
The name of the instance type.
includeSubTypes Boolean
True to retrieve instances of sub types.

Return Value

IList IFCAnyHandle
The instance handles.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also