Rebar |
A class that can used to access the data between two connected Rebars.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The RebarSplice type exposes the following members.

Name | Description | |
---|---|---|
![]() | ConnectedRebarEnd | Identifies the end of the connected rebar which is part of this splice - 0 for start, 1 for end. |
![]() | ConnectedRebarId | Identifies the connected rebar id of this rebar splice object. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | SourceRebarEnd | Identifies the end of the source rebar which is part of this rebar splice - 0 for start, 1 for end. The source rebar is the one from which this rebar splice was obtained. |
![]() | SourceRebarId | Identifies the source of the target rebar which is part of this rebar splice. The source rebar is the one from which this rebar splice was obtained. |
![]() | SplicePosition | Identifies the splice position. |
![]() | SpliceTypeId | Identifies the id of the Rebar Splice Type. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the RebarSplice |
![]() | GetRebarSpliceGeometry | Gets the RebarSpliceGeometry. |
![]() | MoveRebarSpliceGeometry | Moves the RebarSpliceGeometry with the specified vector. |
![]() | RotateRebarSpliceGeometry | Rotates the RebarSpliceGeometry about the given axis and angle. |