RebarSplice Class


Rebar Splice Class

A class that can used to access the data between two connected Rebars.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarSplice

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarSplice : IDisposable

The RebarSplice type exposes the following members.

Properties
Name Description
Public property ConnectedRebarEnd Identifies the end of the connected rebar which is part of this splice - 0 for start, 1 for end.
Public property ConnectedRebarId Identifies the connected rebar id of this rebar splice object.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property SourceRebarEnd Identifies the end of the source rebar which is part of this rebar splice - 0 for start, 1 for end. The source rebar is the one from which this rebar splice was obtained.
Public property SourceRebarId Identifies the source of the target rebar which is part of this rebar splice. The source rebar is the one from which this rebar splice was obtained.
Public property SplicePosition Identifies the splice position.
Public property SpliceTypeId Identifies the id of the Rebar Splice Type.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the RebarSplice
Public method GetRebarSpliceGeometry Gets the RebarSpliceGeometry.
Public method MoveRebarSpliceGeometry Moves the RebarSpliceGeometry with the specified vector.
Public method RotateRebarSpliceGeometry Rotates the RebarSpliceGeometry about the given axis and angle.
Top
See Also