KeynoteEntry Class


Keynote Entry Class

Represents an entry in the keynote table, containing the key value, keynote text, and parent key (if applicable).
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class KeynoteEntry : KeyBasedTreeEntry

The KeynoteEntry type exposes the following members.

Constructors
Name Description
Public method KeynoteEntry(String, String) Constructs a new KeynoteEntry from the given key name and keynote text. KeynoteEntry objects created from this constructor will not have parents.
Public method KeynoteEntry(String, String, String) Constructs a new KeynoteEntry from the given key name, parent key name, and keynote text.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from KeyBasedTreeEntry )
Public property Key The key of this entry.
(Inherited from KeyBasedTreeEntry )
Public property KeynoteText The text associated with this KeynoteEntry.
Public property ParentKey The parent key of this entry.
(Inherited from KeyBasedTreeEntry )
Top
Methods
Name Description
Public method Dispose
(Inherited from KeyBasedTreeEntry )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetChildrenKeys Gets a collection containing the keys of all children entry objects from this entry.
(Inherited from KeyBasedTreeEntry )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also