Keynote |
Represents an entry in the keynote table, containing the key value, keynote text, and parent key (if applicable).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The KeynoteEntry type exposes the following members.

Name | Description | |
---|---|---|
![]() | KeynoteEntry(String, String) | Constructs a new KeynoteEntry from the given key name and keynote text. KeynoteEntry objects created from this constructor will not have parents. |
![]() | KeynoteEntry(String, String, String) | Constructs a new KeynoteEntry from the given key name, parent key name, and keynote text. |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from KeyBasedTreeEntry ) |
![]() | Key | The key of this entry. (Inherited from KeyBasedTreeEntry ) |
![]() | KeynoteText | The text associated with this KeynoteEntry. |
![]() | ParentKey | The parent key of this entry. (Inherited from KeyBasedTreeEntry ) |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from KeyBasedTreeEntry ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetChildrenKeys | Gets a collection containing the keys of all children entry objects from this entry. (Inherited from KeyBasedTreeEntry ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |