Polymesh |
A class representing one triangular piece - a facet - in a polymesh topology.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The PolymeshFacet type exposes the following members.

Name | Description | |
---|---|---|
![]() | PolymeshFacet | Creates a PolymeshFacet with the supplied vertices. |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | V1 | The first vertex of the facet |
![]() | V2 | The second vertex of the facet |
![]() | V3 | The third vertex of the facet |

Name | Description | |
---|---|---|
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | GetVertices | Returns the three vertices that define this facet |
![]() | ToString | Returns formatted string showing (V1, V2, V3) with values formatted as regular integers (Overrides Object ToString ) |

It can also be used to create TopographySurface. Each facet is defined by indices of three vertices of the polymesh.