PolymeshFacet Class


Polymesh Facet Class

A class representing one triangular piece - a facet - in a polymesh topology.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB PolymeshFacet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PolymeshFacet

The PolymeshFacet type exposes the following members.

Constructors
Name Description
Public method PolymeshFacet Creates a PolymeshFacet with the supplied vertices.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property V1 The first vertex of the facet
Public property V2 The second vertex of the facet
Public property V3 The third vertex of the facet
Top
Methods
Name Description
Public method GetVertices Returns the three vertices that define this facet
Public method ToString Returns formatted string showing (V1, V2, V3) with values formatted as regular integers
(Overrides Object ToString )
Top
Remarks
It can also be used to create TopographySurface. Each facet is defined by indices of three vertices of the polymesh.
See Also