Vertex |
The base class for DirectContext3D vertex streams, which are used to write vertex data into buffers.

System Object
Autodesk.Revit.DB.DirectContext3D VertexStream
Autodesk.Revit.DB.DirectContext3D VertexStreamPosition
Autodesk.Revit.DB.DirectContext3D VertexStreamPositionColored
Autodesk.Revit.DB.DirectContext3D VertexStreamPositionNormal
Autodesk.Revit.DB.DirectContext3D VertexStreamPositionNormalColored
Autodesk.Revit.DB.DirectContext3D VertexStream
Autodesk.Revit.DB.DirectContext3D VertexStreamPosition
Autodesk.Revit.DB.DirectContext3D VertexStreamPositionColored
Autodesk.Revit.DB.DirectContext3D VertexStreamPositionNormal
Autodesk.Revit.DB.DirectContext3D VertexStreamPositionNormalColored
Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The VertexStream type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the VertexStream |

This base class cannot be used directly. Instead, a steam that is specific for each type of vertex must be used.
- Use VertexStreamPosition to insert VertexPosition instances.
- Use VertexStreamPositionColored to insert VertexPositionColored instances.
- Use VertexStreamPositionNormal to insert VertexPositionNormal instances.
- Use VertexStreamPositionNormalColored to insert VertexPositionNormalColored instances.
- Map the vertex buffer.
- Get a stream of the appropriate type from the buffer.
- Add vertices of the same type to the stream. They will be written into the buffer that was used to create the stream.
- Unmap the buffer.