VertexStream Class


Vertex Stream Class

The base class for DirectContext3D vertex streams, which are used to write vertex data into buffers.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class VertexStream : IDisposable

The VertexStream type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the VertexStream
Top
Remarks
This base class cannot be used directly. Instead, a steam that is specific for each type of vertex must be used. The process of putting vertex data into a buffer involves using a stream-buffer pair as follows:
  1. Map the vertex buffer.
  2. Get a stream of the appropriate type from the buffer.
  3. Add vertices of the same type to the stream. They will be written into the buffer that was used to create the stream.
  4. Unmap the buffer.
As an alternative to using streams, it is possible to write data into a buffer using a handle to its mapped memory.
See Also