RebarShapeDefinitionByArc Class


Rebar Shape Definition By Arc Class

Definition of a shape whose size and position can determined by a single arc.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarShapeDefinition
Autodesk.Revit.DB.Structure RebarShapeDefinitionByArc

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarShapeDefinitionByArc : RebarShapeDefinition

The RebarShapeDefinitionByArc type exposes the following members.

Constructors
Properties
Name Description
Public property Type Among those rebar shapes defined by an arc, specify which kind.
Top
Methods
Name Description
Public method AddConstraintArcLength Specify a parameter to drive the arc length of the shape.
Public method AddConstraintChordLength Specify a parameter to drive the chord length (the straight-line distance between the endpoints of the arc).
Public method AddConstraintCircumference Specify a parameter to drive the circumference of the shape.
Public method AddConstraintDiameter Specify a parameter to drive the diameter of the shape.
Public method AddConstraintRadius Specify a parameter to drive the radius of the shape.
Public method AddConstraintSagittaLength Specify a parameter to drive the sagittal length (the height of the circular segment, measured perpendicular to the chord).
Public method GetConstraints Retrieve the list of constraints associated with this definition.
Public method SetArcTypeSpiral Set the RebarShapeDefinitionByArc.Type property to Spiral.
Public method SetConstraints Assign a new list of constraints to this definition.
Top
Remarks
In this shape definition, all dimensions are allowed to be driving dimensions.
See Also