RebarShapeDefinitionByArc Class


Rebar Shape Definition By Arc Class

Definition of a shape whose size and position can determined by a single arc.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarShapeDefinition
Autodesk.Revit.DB.Structure RebarShapeDefinitionByArc

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarShapeDefinitionByArc : RebarShapeDefinition

The RebarShapeDefinitionByArc type exposes the following members.

Constructors
Properties
Name Description
Public property Complete Report whether the shape definition is fully constrained.
(Inherited from RebarShapeDefinition )
Public property IsPlanar Reports whether the shape definition lies within a plane: false if a spiral, true in all other cases.
(Inherited from RebarShapeDefinition )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RebarShapeDefinition )
Public property Type Among those rebar shapes defined by an arc, specify which kind.
Top
Methods
Name Description
Public method AddConstraintArcLength Specify a parameter to drive the arc length of the shape.
Public method AddConstraintChordLength Specify a parameter to drive the chord length (the straight-line distance between the endpoints of the arc).
Public method AddConstraintCircumference Specify a parameter to drive the circumference of the shape.
Public method AddConstraintDiameter Specify a parameter to drive the diameter of the shape.
Public method AddConstraintRadius Specify a parameter to drive the radius of the shape.
Public method AddConstraintSagittaLength Specify a parameter to drive the sagittal length (the height of the circular segment, measured perpendicular to the chord).
Public method AddFormulaParameter Add a formula-driven parameter to the shape definition.
(Inherited from RebarShapeDefinition )
Public method AddParameter Add a parameter to the shape definition.
(Inherited from RebarShapeDefinition )
Public method CheckDefaultParameterValues Check that the shape can be solved with the default parameter values.
(Inherited from RebarShapeDefinition )
Public method Dispose
(Inherited from RebarShapeDefinition )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetConstraints Retrieve the list of constraints associated with this definition.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetParameterDefaultValue Return the parameter's default value as stored in the definition.
(Inherited from RebarShapeDefinition )
Public method GetParameterFormula Return the parameter's formula, if one is associated with it.
(Inherited from RebarShapeDefinition )
Public method GetParameters Return the Ids of the shared parameters in the Definition.
(Inherited from RebarShapeDefinition )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method HasParameter Whether the definition stores the parameter.
(Inherited from RebarShapeDefinition )
Public method RemoveParameter Remove the parameter from the definition.
(Inherited from RebarShapeDefinition )
Public method SetArcTypeSpiral Set the RebarShapeDefinitionByArc.Type property to Spiral.
Public method SetConstraints Assign a new list of constraints to this definition.
Public method SetParameterDefaultValue Change the parameter's value as stored in the definition.
(Inherited from RebarShapeDefinition )
Public method SetParameterFormula Associate a formula with the parameter.
(Inherited from RebarShapeDefinition )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
In this shape definition, all dimensions are allowed to be driving dimensions.
See Also