Rebar |
Definition of a shape whose size and position can determined by a single arc.

System Object
Autodesk.Revit.DB.Structure RebarShapeDefinition
Autodesk.Revit.DB.Structure RebarShapeDefinitionByArc
Autodesk.Revit.DB.Structure RebarShapeDefinition
Autodesk.Revit.DB.Structure RebarShapeDefinitionByArc
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The RebarShapeDefinitionByArc type exposes the following members.

Name | Description | |
---|---|---|
![]() | RebarShapeDefinitionByArc(Document, RebarShapeDefinitionByArcType) | Create a non-spiral shape definition. |
![]() | RebarShapeDefinitionByArc(Document, Double, Double, Int32, Int32) | Create a spiral shape definition. |

Name | Description | |
---|---|---|
![]() | Complete | Report whether the shape definition is fully constrained. (Inherited from RebarShapeDefinition ) |
![]() | IsPlanar | Reports whether the shape definition lies within a plane: false if a spiral, true in all other cases. (Inherited from RebarShapeDefinition ) |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RebarShapeDefinition ) |
![]() | Type | Among those rebar shapes defined by an arc, specify which kind. |

Name | Description | |
---|---|---|
![]() | AddConstraintArcLength | Specify a parameter to drive the arc length of the shape. |
![]() | AddConstraintChordLength | Specify a parameter to drive the chord length (the straight-line distance between the endpoints of the arc). |
![]() | AddConstraintCircumference | Specify a parameter to drive the circumference of the shape. |
![]() | AddConstraintDiameter | Specify a parameter to drive the diameter of the shape. |
![]() | AddConstraintRadius | Specify a parameter to drive the radius of the shape. |
![]() | AddConstraintSagittaLength | Specify a parameter to drive the sagittal length (the height of the circular segment, measured perpendicular to the chord). |
![]() | AddFormulaParameter | Add a formula-driven parameter to the shape definition. (Inherited from RebarShapeDefinition ) |
![]() | AddParameter | Add a parameter to the shape definition. (Inherited from RebarShapeDefinition ) |
![]() | CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values. (Inherited from RebarShapeDefinition ) |
![]() | Dispose | (Inherited from RebarShapeDefinition ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetConstraints | Retrieve the list of constraints associated with this definition. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetParameterDefaultValue | Return the parameter's default value as stored in the definition. (Inherited from RebarShapeDefinition ) |
![]() | GetParameterFormula | Return the parameter's formula, if one is associated with it. (Inherited from RebarShapeDefinition ) |
![]() | GetParameters | Return the Ids of the shared parameters in the Definition. (Inherited from RebarShapeDefinition ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | HasParameter | Whether the definition stores the parameter. (Inherited from RebarShapeDefinition ) |
![]() | RemoveParameter | Remove the parameter from the definition. (Inherited from RebarShapeDefinition ) |
![]() | SetArcTypeSpiral | Set the RebarShapeDefinitionByArc.Type property to Spiral. |
![]() | SetConstraints | |
![]() | SetParameterDefaultValue | Change the parameter's value as stored in the definition. (Inherited from RebarShapeDefinition ) |
![]() | SetParameterFormula | Associate a formula with the parameter. (Inherited from RebarShapeDefinition ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

In this shape definition, all dimensions are allowed to be driving dimensions.