Rebar |
Definition of a shape whose size and position can determined by a single arc.

System Object
Autodesk.Revit.DB.Structure RebarShapeDefinition
Autodesk.Revit.DB.Structure RebarShapeDefinitionByArc
Autodesk.Revit.DB.Structure RebarShapeDefinition
Autodesk.Revit.DB.Structure RebarShapeDefinitionByArc
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The RebarShapeDefinitionByArc type exposes the following members.

Name | Description | |
---|---|---|
![]() | RebarShapeDefinitionByArc(Document, RebarShapeDefinitionByArcType) | Create a non-spiral shape definition. |
![]() | RebarShapeDefinitionByArc(Document, Double, Double, Int32, Int32) | Create a spiral shape definition. |

Name | Description | |
---|---|---|
![]() | Type | Among those rebar shapes defined by an arc, specify which kind. |

Name | Description | |
---|---|---|
![]() | AddConstraintArcLength | Specify a parameter to drive the arc length of the shape. |
![]() | AddConstraintChordLength | Specify a parameter to drive the chord length (the straight-line distance between the endpoints of the arc). |
![]() | AddConstraintCircumference | Specify a parameter to drive the circumference of the shape. |
![]() | AddConstraintDiameter | Specify a parameter to drive the diameter of the shape. |
![]() | AddConstraintRadius | Specify a parameter to drive the radius of the shape. |
![]() | AddConstraintSagittaLength | Specify a parameter to drive the sagittal length (the height of the circular segment, measured perpendicular to the chord). |
![]() | GetConstraints | Retrieve the list of constraints associated with this definition. |
![]() | SetArcTypeSpiral | Set the RebarShapeDefinitionByArc.Type property to Spiral. |
![]() | SetConstraints | |

In this shape definition, all dimensions are allowed to be driving dimensions.