RebarSpliceUtils Class


Rebar Splice Utils Class

Class with different utilities for Rebar Splice.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarSpliceUtils

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class RebarSpliceUtils

The RebarSpliceUtils type exposes the following members.

Methods
Name Description
Public method Static member CanRebarBeSpliced(Rebar, RebarSpliceOptions, RebarSpliceGeometry) Verifies if the rebar can be spliced with the RebarSpliceGeometry.
Public method Static member CanRebarBeSpliced(Rebar, RebarSpliceOptions, Line, ElementId) Verifies if the rebar can be spliced with the provided line.
Public method Static member CanRebarBeSpliced(Rebar, RebarSpliceOptions, Line, XYZ) Verifies if the rebar can be spliced with the provided line.
Public method Static member GetLapDirectionForSpliceGeometryAndPosition This function calculates the lap direction given a RebarSpliceGeometry and a RebarSplicePosition.
Public method Static member GetSpliceChain Returns all the rebars that are part of a splice chain with the input rebar.
Public method Static member GetSpliceGeometries Computes a list of RebarSpliceGeometry which respects the rules. This list can be used to splice the Rebar.
Public method Static member SpliceRebar(Document, ElementId, RebarSpliceOptions, IList RebarSpliceGeometry ) Splice a rebar with a list of RebarSpliceGeometry.
Public method Static member SpliceRebar(Document, ElementId, RebarSpliceOptions, Line, ElementId) Splice a Rebar with a line.
Public method Static member SpliceRebar(Document, ElementId, RebarSpliceOptions, Line, XYZ) Splice a rebar with a line.
Public method Static member UnifyRebarsIntoOne This method will unify the rebars by removing the splice between them. A new rebar will be created because of this operation. The curves of the resulted rebar will be the curves of the first rebar continued by the curves of the second rebar. The resulted rebar will take data from the first rebar. (e.g.. layout, moved/removed bars, etc.).
Top
See Also