Rebar |
Class with different utilities for Rebar Splice.

System Object
Autodesk.Revit.DB.Structure RebarSpliceUtils
Autodesk.Revit.DB.Structure RebarSpliceUtils
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The RebarSpliceUtils type exposes the following members.

Name | Description | |
---|---|---|
![]() ![]() | CanRebarBeSpliced(Rebar, RebarSpliceOptions, RebarSpliceGeometry) | Verifies if the rebar can be spliced with the RebarSpliceGeometry. |
![]() ![]() | CanRebarBeSpliced(Rebar, RebarSpliceOptions, Line, ElementId) | Verifies if the rebar can be spliced with the provided line. |
![]() ![]() | CanRebarBeSpliced(Rebar, RebarSpliceOptions, Line, XYZ) | Verifies if the rebar can be spliced with the provided line. |
![]() ![]() | GetLapDirectionForSpliceGeometryAndPosition | This function calculates the lap direction given a RebarSpliceGeometry and a RebarSplicePosition. |
![]() ![]() | GetSpliceChain | Returns all the rebars that are part of a splice chain with the input rebar. |
![]() ![]() | GetSpliceGeometries | Computes a list of RebarSpliceGeometry which respects the rules. This list can be used to splice the Rebar. |
![]() ![]() | SpliceRebar(Document, ElementId, RebarSpliceOptions, IList RebarSpliceGeometry ) | |
![]() ![]() | SpliceRebar(Document, ElementId, RebarSpliceOptions, Line, ElementId) | Splice a Rebar with a line. |
![]() ![]() | SpliceRebar(Document, ElementId, RebarSpliceOptions, Line, XYZ) | Splice a rebar with a line. |
![]() ![]() | UnifyRebarsIntoOne | This method will unify the rebars by removing the splice between them. A new rebar will be created because of this operation. The curves of the resulted rebar will be the curves of the first rebar continued by the curves of the second rebar. The resulted rebar will take data from the first rebar. (e.g.. layout, moved/removed bars, etc.). |