Element |
A filter used to match elements by their category.

System Object
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementQuickFilter
Autodesk.Revit.DB ElementCategoryFilter
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementQuickFilter
Autodesk.Revit.DB ElementCategoryFilter
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ElementCategoryFilter type exposes the following members.

Name | Description | |
---|---|---|
![]() | ElementCategoryFilter(BuiltInCategory) | Constructs a new instance of a filter to match elements by category. |
![]() | ElementCategoryFilter(ElementId) | Constructs a new instance of a filter to match elements by category. |
![]() | ElementCategoryFilter(BuiltInCategory, Boolean) | Constructs a new instance of a filter to match elements by category, with the option to match all elements which are not of the given category. |
![]() | ElementCategoryFilter(ElementId, Boolean) | Constructs a new instance of a filter to match elements by category, with the option to match all elements which are of the given category. |

Name | Description | |
---|---|---|
![]() | CategoryId | The category id. |

Name | Description | |
---|---|---|

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

// Find all Wall instances in the document by using category filter
ElementCategoryFilter filter = new ElementCategoryFilter(BuiltInCategory.OST_Walls);
// Apply the filter to the elements in the active document,
// Use shortcut WhereElementIsNotElementType() to find wall instances only
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> walls = collector.WherePasses(filter).WhereElementIsNotElementType().ToElements();
String prompt = "The walls in the current document are:\n";
foreach (Element e in walls)
{
prompt += e.Name + "\n";
}
TaskDialog.Show("Revit", prompt);