ElementCategoryFilter Class


Element Category Filter Class

A filter used to match elements by their category.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementQuickFilter
Autodesk.Revit.DB ElementCategoryFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ElementCategoryFilter : ElementQuickFilter

The ElementCategoryFilter type exposes the following members.

Constructors
Name Description
Public method ElementCategoryFilter(BuiltInCategory) Constructs a new instance of a filter to match elements by category.
Public method ElementCategoryFilter(ElementId) Constructs a new instance of a filter to match elements by category.
Public method ElementCategoryFilter(BuiltInCategory, Boolean) Constructs a new instance of a filter to match elements by category, with the option to match all elements which are not of the given category.
Public method ElementCategoryFilter(ElementId, Boolean) Constructs a new instance of a filter to match elements by category, with the option to match all elements which are of the given category.
Top
Properties
Name Description
Public property CategoryId The category id.
Top
Methods
Name Description
Top
Remarks
This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
See Also