Fabrication |
This class represents the fabrication part size map for straights allowing the sizes to be changed from a user interface for multiple straights with diffent sizes.

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The FabricationPartSizeMap type exposes the following members.

Name | Description | |
---|---|---|
![]() | FabricationPartSizeMap(String, Double, Double, Boolean) | Creates a new instance of the FabricationPartSizeMap class. |
![]() | FabricationPartSizeMap(String, Double, Double, Boolean, ConnectorProfileType, Int32, Int32) | Creates a new instance of the FabricationPartSizeMap class. |

Name | Description | |
---|---|---|
![]() | AllowMultipleServiceSizes | State flag to allow multiple services to include the same size. |
![]() | Depth | The depth of the straight. |
![]() | IsMappedProductList | Are the mapped sizes for a product listed fabrication part. |
![]() | IsProductList | Are the sizes for a product listed fabrication part. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | MappedDepth | The mapped size for the depth of the straight. |
![]() | MappedProfileType | The mapped shape of the straight. |
![]() | MappedServiceId | The mapped service identifier of the straight. |
![]() | MappedWidthDiameter | The mapped size for the width or diameter of the straight. |
![]() | PaletteId | The palette identifier of the straight. |
![]() | ProfileType | The shape of the straight. |
![]() | ServiceId | The service identifier of the straight. |
![]() | SizeString | The size display string for the straight that can be used by the user interface. |
![]() | WidthDiameter | The width or diameter of the straight. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the FabricationPartSizeMap |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

This is used as the data container for the FabricationPartSizeMapSet typeDef for crs:Set or Autodesk.Revit.DB.Fabrication.FabricationPartSizeMap for ISet so a list of sizes can be generated to allow the user to select a size and map it to another.