FabricationPartSizeMap Class


Fabrication Part Size Map Class

This class represents the fabrication part size map for straights allowing the sizes to be changed from a user interface for multiple straights with diffent sizes.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Fabrication FabricationPartSizeMap

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FabricationPartSizeMap : IDisposable

The FabricationPartSizeMap type exposes the following members.

Constructors
Name Description
Public method FabricationPartSizeMap(String, Double, Double, Boolean) Creates a new instance of the FabricationPartSizeMap class.
Public method FabricationPartSizeMap(String, Double, Double, Boolean, ConnectorProfileType, Int32, Int32) Creates a new instance of the FabricationPartSizeMap class.
Top
Properties
Name Description
Public property AllowMultipleServiceSizes State flag to allow multiple services to include the same size.
Public property Depth The depth of the straight.
Public property IsMappedProductList Are the mapped sizes for a product listed fabrication part.
Public property IsProductList Are the sizes for a product listed fabrication part.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property MappedDepth The mapped size for the depth of the straight.
Public property MappedProfileType The mapped shape of the straight.
Public property MappedServiceId The mapped service identifier of the straight.
Public property MappedWidthDiameter The mapped size for the width or diameter of the straight.
Public property PaletteId The palette identifier of the straight.
Public property ProfileType The shape of the straight.
Public property ServiceId The service identifier of the straight.
Public property SizeString The size display string for the straight that can be used by the user interface.
Public property WidthDiameter The width or diameter of the straight.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the FabricationPartSizeMap
Top
Remarks
This is used as the data container for the FabricationPartSizeMapSet typeDef for crs:Set or Autodesk.Revit.DB.Fabrication.FabricationPartSizeMap for ISet so a list of sizes can be generated to allow the user to select a size and map it to another.
See Also