AreElementsValidForAssembly Method


Assembly Instance Are Elements Valid For Assembly Method

Identifies if provided assembly members are valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool AreElementsValidForAssembly(
	Document document,
	ICollection<ElementId> assemblyMemberIds,
	ElementId assemblyId
)

Parameters

document Document
The document.
assemblyMemberIds ICollection ElementId
Element ids to be tested for validity for membership of an assembly instance.
assemblyId ElementId
Id of the existing assembly to add components to. If invalid, the method return whether the components can be added to a new assembly

Return Value

Boolean
True if all member ids are valid, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also