Rebar |
This class encapsulates the options for the rebar splice operation.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The RebarSpliceOptions type exposes the following members.

Name | Description | |
---|---|---|
![]() | RebarSpliceOptions | Constructs a RebarSpliceOptions |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | SplicePosition | Identifies the splice line position. |
![]() | SpliceTypeId | Identifies the id of the Rebar Splice Type. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the RebarSpliceOptions |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |