RebarSpliceOptions Class


Rebar Splice Options Class

This class encapsulates the options for the rebar splice operation.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarSpliceOptions

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarSpliceOptions : IDisposable

The RebarSpliceOptions type exposes the following members.

Constructors
Name Description
Public method RebarSpliceOptions Constructs a RebarSpliceOptions
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property SplicePosition Identifies the splice line position.
Public property SpliceTypeId Identifies the id of the Rebar Splice Type.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the RebarSpliceOptions
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also