FilterInverseRule Class


Filter Inverse Rule Class

A filter rule that inverts the boolean values returned by the rule it contains.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB FilterRule
Autodesk.Revit.DB FilterInverseRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FilterInverseRule : FilterRule

The FilterInverseRule type exposes the following members.

Constructors
Name Description
Public method FilterInverseRule Constructs a new instance of FilterInverseRule.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from FilterRule )
Top
Methods
Name Description
Public method Dispose
(Inherited from FilterRule )
Public method ElementPasses Derived classes override this method to implement the test that determines whether the given element passes this rule or not.
(Inherited from FilterRule )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetInnerRule Gets the rule being inverted.
Public method GetRuleParameter Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter.
(Inherited from FilterRule )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetInnerRule Gets the rule being inverted.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
FilterInverse rule performs a logical "not" operation on its inner rule's "elementPasses()" method.
See Also