Filter |
A filter rule that inverts the boolean values returned by the rule it contains.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The FilterInverseRule type exposes the following members.

Name | Description | |
---|---|---|
![]() | FilterInverseRule | Constructs a new instance of FilterInverseRule. |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from FilterRule ) |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from FilterRule ) |
![]() | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetInnerRule | Gets the rule being inverted. |
![]() | GetRuleParameter | Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter. (Inherited from FilterRule ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | SetInnerRule | Gets the rule being inverted. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

FilterInverse rule performs a logical "not" operation on its inner rule's "elementPasses()" method.