EntryAndSchemeConsistency Enumeration


Entry And Scheme Consistency Enumeration

Enumeration used to specify why an entry is inconsistent with a scheme or another entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum EntryAndSchemeConsistency
Members
Member name Value Description
Consistent 0 The scheme entry can be applied to the scheme.
InconsistentStorageType 1 The type of value stored in the entry is different from the type of the scheme parameter.
ValueOutOfRange 2 The value stored in the entry is out of the scheme parameter range.
ValueDuplicated 3 There already exists another entry with the same value.
InvalidFillPatternId 4 The fill pattern id is not valid.
See Also